Page 1 of 1

BeagleBone Blue

PostPosted: Tue Jun 06, 2017 8:50 am
by gabemgem
Is there any way to connect to and program a BeagleBone Blue with LINX and LabView?

Re: BeagleBone Blue

PostPosted: Tue Jun 06, 2017 3:40 pm
by sharpk
Hi gabemgem,

There have been some tests run on a BB Blue and LabVIEW VIs should work fine, but the LINX I/O library was designed for the BB Black and since the pinouts on the BB Blue are completely different it likely won't work very well.

Regards,
Ken

Re: BeagleBone Blue

PostPosted: Wed Jun 07, 2017 8:20 am
by gabemgem
Thanks Ken, I was coming to that conclusion as well. How would you suggest getting the VI's to run on the BeagleBone then?

-Gabe

Re: BeagleBone Blue

PostPosted: Wed Jun 07, 2017 3:53 pm
by sharpk
Hi Gabe,

There are a couple of options for getting the BB Blue I/O working in LabVIEW, but none of them are particularly easy:

1. Since the LINX library is open source you could modify it to work on the BB Blue. This would require writing and modifying C++ code. I'm also not sure how well the LINX API would map to the BBBlue since the I/O on that board is very different (IMUs, motor and servo controllers, etc.) The source is available here.

2. There is an I/O library meant just for the BBBlue called the robotics cape library. You could take that library and wrap it in LabVIEW VIs. Someone has been going down this path, and there is some beginning work here, but as far as I know there's little or no documentation yet.

-Ken

Re: BeagleBone Blue

PostPosted: Sat Mar 23, 2019 6:46 pm
by jack_001
Hi Ken,

I cannot to enable the robotics cape device tree on BeagleBone Blue.

#~ sudo configure_robotics_dt.sh
#~ reboot

I am trying but no succes.

Jack.