Page 1 of 1

Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels

PostPosted: Wed Aug 09, 2017 5:19 am
by Kryptman
If you have the following error on a raspberry pi, I may have a solution for you:

Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.viLMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.vi loaded with errors on the target and was closed.
Deployment completed with errors

As the linx install supports the beaglebone black and the raspberry pi, there are two shared libraries which define the devices on the target board. What I think is supposed to happen during the install is that a symlink is created for the matching library. Sometimes, this does not happen.

Here's how to fix this:

Drop to a command line on the pi and type in the following commands:

cd /srv/chroot/labview
sudo schroot --run-session -c lv


This will drop you into the chroot environment in which labview runs.

cd /usr/lib
ls liblinx*


This should show you two files, namely liblinxdevice_rpi2.so and liblinxdevice_bbb.so
. If you have three files here, this fix will not work, and there's something else wrong.

Ok, now we create a symlink called liblinxdevice.so. This symlink should have been created during installation or when first running the linx environment, but for some reason, it's not.

Type in ln -s ./liblinxdevice_rpi2.so ./liblinxdevice.so.

If you try your deployment now, it should work properly.

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Sun Sep 10, 2017 8:32 pm
by teslafuentes
I'm trying to use the new Stretch version of Raspbian on a Raspberry Pi 2 with Linx 3 and I'm getting the same error:
Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.viLMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.vi loaded with errors on the target and was closed.

I do notice that when I'm trying to install LabVIEW on the Pi and it says that I have successfully connected, it doesn't give me the Pi Logo and neither the IP address of the target as it will do with Jessie.

Please see attached file with images and I'll appreciate any help I can get.

Lauren

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Mon Sep 11, 2017 11:40 am
by Zam
teslafuentes wrote:I'm trying to use the new Stretch version of Raspbian on a Raspberry Pi 2 with Linx 3 and I'm getting the same error:
Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.viLMH-LINX.lvlib:Local IO.lvlib:Load Device Channels.vi loaded with errors on the target and was closed.

I do notice that when I'm trying to install LabVIEW on the Pi and it says that I have successfully connected, it doesn't give me the Pi Logo and neither the IP address of the target as it will do with Jessie.

Please see attached file with images and I'll appreciate any help I can get.

Lauren


I have exactly the same problem! :(

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Fri Oct 20, 2017 11:06 am
by Kryptman
Hi,

I installed linx on stretch successfully. The culprit is security. The scripts require sudo with NO password to work properly, so when it tries to install, it gets to a sudo command and then dies because there's noone to enter the sudo password.

On newer releases, I recommend using the manual install method. This has worked on stretch on a PI and a BBB perfectly...

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Fri Oct 20, 2017 12:06 pm
by teslafuentes
Thanks! But can you explain yourself with what you mean SUDO without Password?

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Fri Oct 20, 2017 3:10 pm
by Kryptman
Ah, ok, I understand the problem.

When you use a linux command line you can use the command "sudo" to do things as superuser. It's like "Run as administrator" on windows. I think starting with stretch or jessie (can't remember which) the "sudo" command asks for the user's password. This is a security feature. Now, if a script is triggered and it executes a command like

sudo sh -c 'echo "deb http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'


the system expects to be given a password. Since this command is encapsulated inside the install script for linx, there's noone there to enter the password when linux wants it. Therefore things start to fail. There are now two options: configure linux NOT to ask for the password, which is in effect weakening the security of you linux system, or you run the installation manually. Doing the installation manually, without the labview makerhub installer is really easy though. It's just three commands:

sudo sh -c 'echo "deb http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
sudo apt-get update
sudo apt-get install -y --force-yes lvrt-schroot


You can get detailed instructions from here:

https://www.labviewmakerhub.com/doku.php?id=learn:libraries:linx:misc:target-manual-install

As I said before, doing a manual install like this has solved literally all installation problems I had on the pi and the bbb...

Re: Deploying LMH-LINX.lvlib:Local IO.lvlib:Load Device Chan

PostPosted: Mon Oct 23, 2017 7:30 am
by teslafuentes
Thanks again!
I'll try the manual option.