Page 1 of 1

LINX+Arduino+LabVIEW mass compile error

PostPosted: Fri Jan 10, 2020 9:49 am
by KKmm
Hi! I have an issue with not being able to run the LINX example (Blink Simple) for my Arduino MEGA in LabVIEW. I am using LabVIEW 2019 (32-bit), 2019 JKI VI Package Manage, Diligent LINX (version 3.0.1.192) on Windows 7 (64-bit). So the issue here is that I am not able to run the program and when I click on the broken arrow, it says I have no errors. It seems that the error is with the Loop Frequency.

I was following this [https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000001DdHkSAK&l=nl-NL] link and tried to force a recompile - did not work. I ran the mass compile and there are indeed a problem with the Loop Frequency, but what can I do about it? How can I fix it?

Also, when I was trying other examples, there is an issue with other VIs as well. I posted the same question [https://forums.jki.net/topic/3059-linx-broken-arrow-issue-in-labview/] here, but have not received any opinion or so. I am hoping maybe someone here has an experience with a similar issue.

Re: LINX+Arduino+LabVIEW mass compile error

PostPosted: Sat Jan 11, 2020 11:19 am
by toshas
Diligent LINX version 3.0.1.192 is compatible only with Labview 2014 32-bit.

Re: LINX+Arduino+LabVIEW mass compile error

PostPosted: Mon Jan 13, 2020 9:10 am
by KKmm
Thank you, toshas! I did not notice this compatibility. It was written ''Compatible LabVIEW Versions: >= 2011'' and I thought it is good enough.

But does it mean that there is no compatible version of Diligent LINX for LabVIEW 2019?

Re: LINX+Arduino+LabVIEW mass compile error

PostPosted: Tue Jan 14, 2020 4:01 am
by toshas
LINX for 2019 and 2020 has beta status.
For access sign up here https://ni.com/beta